Du bist nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Deutsches Simutrans Forum. Falls dies dein erster Besuch auf dieser Seite ist, lies bitte die Hilfe durch. Dort wird dir die Bedienung dieser Seite näher erläutert. Darüber hinaus solltest du dich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutze das Registrierungsformular, um dich zu registrieren oder informiere dich ausführlich über den Registrierungsvorgang. Falls du dich bereits zu einem früheren Zeitpunkt registriert hast, kannst du dich hier anmelden.

1

Freitag, 6. Dezember 2013, 20:16

Factory spacing

Hallo,

ich wollte mir gerade eine neue pak128 Karte mit der aktuellen stable erstellen, nur leider scheint factory spacing irgendeinen Murks zu machen. Sowohl bei 40% innerhalb 100 Felder als auch 100% innerhalb 100 Felder versucht es die Fabriken eines Industriezweiges möglichst weit auf der Karte zu verteilen. Dazu sind aktuell etwa 90% der Fabriken am linken Kartenrand. Min spacing ist auf 1

2

Freitag, 6. Dezember 2013, 22:51

Ist evt. links die einzig geeignete Klimazone?

Ansonsten sind deine Angabe etwas zu knapp: Was hast du genau eingestellt, bzw. was hast du erwartet?

3

Samstag, 7. Dezember 2013, 09:25

Die neue Karte war grob 3000x3000, daher sollten Klimazonenprobleme nicht auftauchen. Ich habe auf meinen Karten mit pak128 min_spacing stets auf 1 gestellt, damit die Industriegebiete überhaupt Platz finden. Mit dem neuen Parameter wollte ich eigentlich nichts anfangen, habe aber max_spacing percentage auf 40 gestellt und max_spacing auf 100, wobei ich dachte, dass das bedeutet das 40% (mindestens oder auch nicht) der Zulieferer einer Fabrik höchstens 100 Felder entfernt entstehen.

Norman

Fortgeschrittener

Beiträge: 521

Beruf: Äkschänfidjoschdar

  • Private Nachricht senden

4

Samstag, 7. Dezember 2013, 09:55

max_spacing percentage auf 40

interpretiere ich als maximalen Abstand von 40% der Kartengröße.

5

Samstag, 7. Dezember 2013, 21:55

Wenn beides spezifiziert ist, wird nur eines genommne. Im übrigen gilt dies nur für Verbraucher, die neu dazukommen. Verbindungen zu bereits existierenden Verbrauchern gehen auch über die ganze Karte.

6

Sonntag, 8. Dezember 2013, 07:57

Ich habe jetzt mal einen Screenshot einer neu erstellten Karte gemacht.


Diesmal wurden tatsächlich einfach die vorgegebenen Einstellungen verwendet

7

Sonntag, 8. Dezember 2013, 23:33

Ist vielleicht Zufall. Bis zu einer Kartengröße von 3000x1000 (mehr kann mein Rechner nicht in utner 10 Minuten) gibt es zwar manchmal Häufungen Oben und Links, aber ebenso oft auch durchaus durchmischte Karten.

8

Montag, 9. Dezember 2013, 07:53

Zufall....hmmm
Ich habe jetzt 4x eine neue Karte erstellt und das Ergebnis war quasi identisch, sprich unbrauchbar.
Ich habe es jetzt quasi manuell probiert, also eine Karte ohne Industrieketten erstellt. Die ersten Ketten, die ich mit dem Tool der öffentlichen Hand erstellen ließ wurden normal auf der Karte verteilt ("normal", einfach wild verteilt, ohne dass man sie in den nächsten 20 Spieljahren verbinden könnte)
Die späteren Ketten landeten am linken Kartenrand

9

Montag, 9. Dezember 2013, 16:57

Es wird aber in allen Faellen die gleiche Funktion aufgerufen ?(

10

Montag, 9. Dezember 2013, 20:47

Naja die Information die ich weitergeben wollte, war auch ehr, dass die ersten gesetzten Industrieketten in Ordnung sind und erst nach ein paar Ketten auf einmal alles am linken Kartenrand landet. Zwischen Industrieketten bei der Kartenerstellung setzen und Industrieketten danach setzen ist wirklich kein Unterschied erkennbar gewesen

11

Mittwoch, 11. Dezember 2013, 09:44

Gerade mit pak64 probiert, gleiches Problem. Was könnte ich noch testen, um diesem Problem auf die Spur zu kommen?

12

Mittwoch, 11. Dezember 2013, 10:43

Ich konnte es nicht reproduzieren. Je nach Spiel mal mehr links, mal mehr oben, mal unten und natuerlich auch in der Mitte. Nur rechts sind es immer wenige. (Allerdings waren da, Zufall oder nicht, auch deutlich weniger Staedte.)

13

Mittwoch, 11. Dezember 2013, 11:24

Ich habe es gerade mit der aktuellen nightly probiert, ich habe allerdings die "vollständige" nightly runtergeladen und die alte Kopie überschrieben. Das Problem ist zwar weniger stark ausgeprägt, aber immer noch vorhanden.
Jetzt wollte ich die Fabrikenliste verwenden, um dir genauere Werte zu liefern, wie viele Fabriken wie nahe am linken Kartenrand sind.
Allerdings sind die Angaben bei vielen Fabriken fehlerhaft/unvollständig:
Fertigwarenfabrik(0+0, 0, 826) dabei ist die Fabrik in 11, 2548
Anbei ein Bild, das die fehlerhafte Liste zeigt, und das übliche wenn auch nicht mehr so schlimme Verteilungsproblem

14

Mittwoch, 11. Dezember 2013, 11:45

Die Werte sind nicht die Koordinaten, sondern die Lagerhaltung und wieviel unterwegs ist ...

15

Mittwoch, 11. Dezember 2013, 11:55

Ups, ich hoffe das war wenigstens früher anders ;)

16

Freitag, 13. Dezember 2013, 01:06

Kenne das problem ...
... bei mir war die "lösung" folgende:
1. Bergikeit um eins erhöhen (alle anderen werte beibehalten) karte erstellen
2. Bergikeit wieder um eins minimieren karte neu erstellen
=> in gefühlt 75% der fälle waren die Industrieketten dann relativ gut verteilt.

Bis denn, dann
Aprisus
Mein YT Kanal: Aprisus 8)
Europa Karte mit 93 Städten, die nach natürlichen Standortenplatziert wurden im Let's Play: Europa Let's Play Staffel 1 mit mitlerweile über 100 Folgen 8)
* NEU * Europa Let's Play Staffel 2

viel spass beim schauen :D

Bis denn, dann
Aprisus

17

Freitag, 13. Dezember 2013, 07:00

Danke für die Information Aprisus, ich werde es wohl heute nachmittag mal ausprobieren. Kannst du vielleicht noch genauere Details nennen, wann der Bug bei dir auftritt?
Edit: Funktioniert tatsächlich, ich bin zwar jetzt verwirrt, habe eine Karte -> win? ;)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »dom700« (13. Dezember 2013, 18:32) aus folgendem Grund: Doppelposting vermeiden :)


18

Sonntag, 15. Dezember 2013, 00:09

Freut mich erstmal das mein Tip geholfen hat :thumbup:
Genauere Detail puuuhh aus dem kopf weis ich jetzt nix weiter und da ich grad auch nur eine Karte spiele siehe Youtube => Europa Let's Play
müsste ich es erst wieder ausprobieren da ich heute am Sonntag dazu keine Zeit habe wird das erst am Montag werden.
Welche Details willst denn wissen?

Bis denn, dann
Aprisus
Mein YT Kanal: Aprisus 8)
Europa Karte mit 93 Städten, die nach natürlichen Standortenplatziert wurden im Let's Play: Europa Let's Play Staffel 1 mit mitlerweile über 100 Folgen 8)
* NEU * Europa Let's Play Staffel 2

viel spass beim schauen :D

Bis denn, dann
Aprisus

19

Sonntag, 15. Dezember 2013, 01:12

Das sollte eigentlich genau gar nicht ändern. Ändern der Rauhigkeit beeinflusst nicht einmal den normalen Zufallsgenerator. Nur das erstellen einer Karte ändert den Zufallsgenerator. D.h. das gleiche Ergebnis wird auch rauskommen, wenn die die Karte zweimal neu erstellst.

20

Sonntag, 15. Dezember 2013, 08:24

@Aprisius Ich dachte jetzt eher, dass du vielleicht weitere Details hättest, wann es bei dir aufgetreten ist.
@Prissi Also jetzt nach dem ersten Versuch, bei dem es geklappt hat, sind die Fabriken wieder auffällig am linken Kartenrand. Ich lasse jetzt noch ein paar Karten erstellen, aber ich nehme an, eine Kontrollmessung ohne Änderung des Parameters würde die gleichen Ergebnisse produzieren, sprich manchmal werden die Fabriken eben doch ok verteilt.

Edit: Ich wüsste halt gerne, ob der Algorithmus geändert wurde. Die Industrieketten wurden vorher immer völlig anders erstellt: Die Ketten waren deutlich kompakter, mit min factory spacing auf 1 saßen die Fabriken so nah zusammen, dass man etwa einen Bahnhof für zwei Nutzwälder einrichten konnte. Jetzt ist es so, dass ich zu Beginn keine Industriegruppe mit dem normalen Anfangskapital verbinden könnte.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »dom700« (15. Dezember 2013, 08:35)